Суббота, 23 Март 2013 23:15

Настройка собственного облачного хранилища

Автор
Оцените материал
(10 голосов)

После того, как я, наконец, установил дополнительный SSD на свой домашний сервер, то мне, в первую очередь, захотелось настроить собственное облачное хранилище.

Из opensource решений я знаю только Owncloud. И как раз, пару недель назад вышла пятая версия Owncloud. Вначале я попытался поставить её, но потом отказался от этой идеи, поскольку, во-первых, эта пятая версия упорно не хотела работать на nginx, выдавая ошибку:

This content failed to load.

При этом никакие рекомендации, описанные здесь:

http://forum.owncloud.org/viewtopic.php?f=23&t=9013

мне не помогли.

А во-вторых, для пятой версии ещё не вышел ownCloud Desktop Client. Поэтому я решил ставить версию 4.5.8.

Итак, сперва-наперво, обновим порты во FreeBSD:

portsnap fetch update

Теперь смотрим, какие пакеты нужны для Owncloud:

http://doc.owncloud.org/server/5.0/admin_manual/installation/installation_source.html

И вроде бы, у меня всё стоит, кроме smbclient. Честно говоря, не знаю, пригодится ли оно, но поставить ведь не сложно:

cd /usr/ports/net/samba-smbclient
make install clean

В зависимостях опции сборки оставил по умолчанию.

Но чтобы 100% быть уверенным, что всё необходимое для owncloud у меня есть, я решил сначала поставить owncloud прямо из портов. К этому времени, там тоже уже была 5-я версия. Ставлю:

cd /usr/ports/www/owncloud
make install clean

И не зря я так поступил, потому как owncloud потянул за собой некторые зависимости: mp3info и php53-pdo_mysql. Поэтому делаем вот такие команды:

rehash
service php-fpm restart

Теперь